顶部导航开始 -->

yii2 开源插件与系统

yii2干货集:https://github.com/forecho/awesome-yii2

商城

samdark/yii2-shop
  composer global require "fxp/composer-asset-plugin:~1.1.0"
  composer create-project --prefer-dist --stability=dev samdark/yii2-minimal path/to/your/project
  
omnilight/yii2-shopping-cart
  composer require --prefer-dist omnilight/yii2-shopping-cart "*"
  
yii2mod/yii2-cart
  composer require --prefer-dist yii2mod/yii2-cart "*"
  
funson86/funshop
    NullRefExcep/yii2-shopper

后台搭建:

mdmsoft/yii2-admin  &&  dmstr/yii2-adminlte-asset
  composer require mdmsoft/yii2-admin "~2.0"
  composer require dmstr/yii2-adminlte-asset "2.*"
  
liulipeng/Yii2-Admin
    #基于liulipeng/yii2-app-advanced,直接就是一个yii2 advanced系统,方便快捷,
    #唯一缺点是gii中curd以后需要改动模板才可正常显示)
  composer global require "fxp/composer-asset-plugin:~1.1.1"
  composer create-project --prefer-dist izyue/yii2-app-advanced advanced
  
izyue/yii2-admin
  composer require izyue/yii2-admin "dev"

微信公众号

callmez/yii2-wechat-sdk
  composer require callmez/yii2-wechat-sdk "dev-master"

thenbsp/wechat 
    #微信公众平台第三方 SDK 开发包,优雅、健壮,可扩展,遵循 PSR 开发规范。
  composer require thenbsp/wechat

小程序

kulokai/weapp_wechat_miniapp_sdk
    一个封装了微信小程序服务端接口的SDK
    composer require jiaweixs/weapp
    
wxpay/WXPay-SDK-PHP
    微信小程序支付 PHP SDK
    $ composer require "wxpay/wxpay:0.0.5" -vvv

设置

funson86/yii2-setting
  composer require funson86/yii2-setting "*"

图表

2amigos/yii2-chartjs-widget
  composer require 2amigos/yii2-chartjs-widget:~2.0
2amigos/yii2-highcharts-widget
  composer require 2amigos/yii2-highcharts-widget:~1.0

日期

2amigos/yii2-date-picker-widget
  composer require 2amigos/yii2-date-picker-widget:~1.0

图片处理

yiisoft/yii2-imagine
  composer require --prefer-dist yiisoft/yii2-imagine

短信发送

daixianceng/yii2-smser
  composer require daixianceng/yii2-smser "*"

模板引擎

yiisoft/yii2-smarty
  composer require --prefer-dist yiisoft/yii2-smarty

菜单

kartik-v/yii2-widget-sidenav
  composer require kartik-v/yii2-widget-sidenav "*"

redis

yiisoft/yii2-redis
  composer require --prefer-dist yiisoft/yii2-redis

评星

kartik-v/bootstrap-star-rating
  composer require kartik-v/bootstrap-star-rating "@dev"
chiliec/yii2-vote
  composer require --prefer-dist chiliec/yii2-vote "^3.0"

二维码

2amigos/yii2-qrcode-helper
  composer require 2amigos/yii2-qrcode-helper:~1.0

分类

creocoder/yii2-nested-sets
  composer require creocoder/yii2-nested-sets
kartik-v/yii2-tree-manager(基于yii2-nested-sets)
  composer require kartik-v/yii2-tree-manager "@dev"

aouth2.0(qq登录、微博登录等)

xj/yii2-oauth
  composer require xj/yii2-oauth "~2.0.0"

Curl

linslin/yii2-curl
  composer require --prefer-dist linslin/yii2-curl "*"

文件上传

fatjiong/yii2-webuploader
  composer require yidashi/yii2-webuploader
iisns/yii2-webuploader
  composer require --prefer-dist iisns/yii2-webuploader "*"
2amigos/yii2-file-upload-widget
  composer require 2amigos/yii2-file-upload-widget:~1.0

编辑器

kartik-v/yii2-markdown
  composer require kartik-v/yii2-markdown "dev-master"
anruence/yii2-editor.md  "^0.1.1"(markdown编辑器)
  composer require anruence/yii2-editor.md
yiidoc/yii2-redactor(富文本编辑器)
  php composer require --prefer-dist yiidoc/yii2-redactor "*"
pjkui/kindeditor
  composer require pjkui/kindeditor "*"

全文搜索

hightman/xunsearch
  composer require --prefer-dist hightman/xunsearch "*@beta"

Excel

moonlandsoft/yii2-phpexcel
  composer.phar require --prefer-dist moonlandsoft/yii2-phpexcel "*"
  
kartik-v/yii2-export
  composer require kartik-v/yii2-export "@dev"

pdf

kartik-v/yii2-mpdf
  composer require kartik-v/yii2-mpdf "dev-master"

Select 

composer require kartik-v/yii2-widget-select2 "@dev"

用户

composer require "dektrium/yii2-user:0.9.*@dev"

弹出框

lichunqiang/yii2-sweet-submit
    composer require light\yii2-sweet-submit=*

实时编辑

bizley/yii2-content-tools
    composer require "bizley/contenttools": "1.0"

api文档编写

lichunqiang/yii2-swagger-demo

数据库备份

Beaten-Sect0r/yii2-db-manager
    composer require --prefer-dist beaten-sect0r/yii2-db-manager "*"

七牛云存储

添加下列代码在composer.json文件中并执行composer update --no-dev操作
{    
    "require": {       
        "chocoboxxf/yii2-qiniu-sdk": "dev-master"
    }
}

支付宝

liulipeng/yii2-alipay
    composer require izyue/yii2-alipay "*"

阿里大鱼短信SDK

songyichao/yii2-taobao
    将阿里大于api整合为composer扩展(虽然名称是yii只要是composer就可以安装使用)
    composer require itsyc/yii2-taobao dev-master


自学php博客
请先登陆后发表评论
  • 最新评论
  • 总共0条评论
  • © 2014-2016 zixuephp.cn 版权所有
  • ICP证:皖ICP备16012107号
  • 联系邮箱:510082587@qq.com
  • 交流请加微信:weibobf2899 或扫下方二维码